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Introduction 
Hydraulic modeling in the Modeling, Mapping, and Consequences (MMC) production center is based on 
uniform base datasets. This document describes how those base datasets are developed by the MMC 
Geographic Information System (GIS) mapping team for delivery to the MMC Hydraulics and Hydrology (H&H) 
modeling team. 

The base datasets described here meet minimum criteria for use in MMC models. If higher quality data is 
available from the district or other source it may be used with guidance from the MMC GIS/Mapping team. All 
data used for MMC modeling must be compatible and comparable to the data described herein. 

Listed are the primary datasets provided to H&H by the GIS/Mapping team: 

Vector: 
• Line of Protection (LOP) 

o Three dimensional (3D) feature class depicting the top of levee, floodwall and closure 
structures around a protected area. Each node on the line should have an elevation (z) 
value. Edited by MMC GIS/Mapping team if necessary. 

• Stream Centerline 
o Digitized by MMC GIS/Mapping team 

• Stream Banklines 
o Digitized by MMC GIS/Mapping team 

• Levee Centerline 
o Exported from the National Levee Database (NLD) as is  

• Floodwall Line 
o Exported from the NLD as is 

• Closure Structure Line 
o Exported from the NLD as is 

• Vertical Datum Conversion Points 
o Points along the centerline containing the conversion factor for converting elevations from 

National Geodetic Vertical Datum of 1929 (NGVD 29) to North American Vertical Datum of 
1988 (NAVD 88) or to the official federally supported vertical datum appropriate to the 
geographical study area 

• Leveed Area Polygon 
o Polygon from the NLD, depicting the leveed area of the LOP 

Raster: 
• DEM (Digital Elevation Model) _Geo 

o Derived from the 10-meter National Elevation Dataset (NED) (latest available version at 
data development time) provided in native geographic projection (NAD83) 

• DEM (Digital Elevation Model) _MMC 
o Derived from the 10-meter NED (latest available version at data development time) 

provided in MMC projection 
• DEM (Digital Elevation Model) _MMC_Lev 
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o Generated from the provided digital elevation model (DEM) with the LOP burned-in 
• DEM (Digital Elevation Model) _MMC_Lev_R 

o Generated from the provided DEM with the LOP burned-in and resampled 
• DEM (Digital Elevation Model) _MMC_Lev_R_ASC  

o ASCII file that was generated from the provided DEM with the LOP burned-in and 
resampled  

• Hillshade  
o Generated from the provided DEM 

The datasets are organized into a standard folder structure that persists throughout the life cycle of the MMC 
process. These files are then delivered to the assigned H&H modeler to begin hydraulic modeling using the 
folder structure described in Appendix 4.3.1, File Schema Guide.  
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Deliverable Package Schema 
All vector files will be provided in ESRI Shapefile (.shp) format. Raster data will be in ESRI Grid format. Within 
the naming conventions described in this document, [Proj_Code] corresponds to the three letter abbreviation 
for the study levee in question.  

2.1 MMC PROJECTION 

The projection used for modeling in the MMC is the USA_Contiguous_Albers_Equal_Area_Conic_USGS 
version projection with the linear units set to US feet. Each data layer below will be noted with either the MMC 
projection or Geographic, which corresponds to the native projection of the NED.  

An ESRI .prj projection file will be provided along with the pre-modeling deliverable that can be used to project 
any data into the MMC projection. It is located in the GIS_Modeling\Projections folder. 

2.2 VECTOR DATA 
Table 2-1. Vector Shapefiles 

Layer Name Naming Convention Projection 

LOP [Proj_Code]_LOP.shp MMC 

Floodwall Line [Proj_Code]_FL.shp MMC 

Closure Structure Line [Proj_Code]_CSL.shp MMC 

Levee Centerline [Proj_Code]_LCL.shp MMC 

River Centerline [Proj_Code]_CL.shp MMC 

Banklines [Proj_Code]_BL.shp MMC 

Conversion Points [Proj_Code]_Conv.shp MMC 

Leveed Area Polygon [Proj_Code]_LA.shp MMC 
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2.3 RASTER DATA 
Table 2-2. Raster Grids 

Layer Name Naming Convention Projection 

Native DEM [Proj_Code]_DEM_Geo Geographic 

Model DEM [Proj_Code]_DEM_MMC MMC 

DEM with Levee [Proj_Code]_ MMC_Lev MMC 

Resampled DEM with Levee [Proj_Code]_ MMC_Lev_R MMC 

ASCII Grid [Proj_Code]_MMC_Lev_R_ASC MMC 

Hillshade [Proj_Code]_HLS MMC 

2.4 OTHER DELIVERABLE FILES 

In addition to the vector and raster base data, an ArcGIS .mxd document with links to each of the datasets as 
well as the ESRI image services will be provided. It can be named “BaseMap.mxd” or “[Study 
Area]_BaseMap.mxd”. Also provided will be the ESRI .prj projection description file set to the MMC projection. 
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Pre-Model Data Development 
The following steps are designed for the GIS/Mapping team member who is assigned to develop the pre-model 
dataset to follow for a given levee. This document is also provided to the H&H modeler as background 
information to describe the development of the data that they are using. The first step to the data production 
process is to locate the study levee via the National Levee Database (NLD).  

Once the levee location is identified and verified against aerial photography, the data production can begin. 
The location of the levee in the NLD should be verified using aerial photography. 

3.1 FOLDER STRUCTURE 

Create the deliverable folder structure shown in Figure 1 and discussed in Appendix 4.3.1 using windows 
explorer or ArcCatalog. Optionally, a zip file containing a blank copy of the folder structure is available from the 
Kansas City District (NWK) and is called MMC_File_Structure.zip. 

Rename the folder called [Study_Levee_Name] to the three digit abbreviation of the study LOP and its NLD 
System ID with all spaces represented by an underscore (i.e., [Proj_Code]_[FC_System_ID]). 

Rename the folder called [Year - Draft or Final] located directly beneath the [Study_ Levee _Name] folder to 
the fiscal year of the assignment and the word Draft separated by a single hyphen (i.e., 2012-Draft). 

Create a folder under the [Year - Draft or Final] folder called Working. All processes covered in this document 
should use this folder as their workspace. Final data layers are moved into the appropriate folders for delivery 
after they are created. The Working folder is not included in the delivery to the modeler, but is archived at 
NWK. 

If the GIS/Mapping Team member developing the data is not at NWK, the Working folder will be sent to NWK 
when the data is submitted. 

3.2 PRE-MODEL GEODATABASE 

All vector data generated in this process, with the exception of the levee centerline, the floodwall line, and the 
closure structure line, should be created directly into the MMC pre-model geodatabase schema or imported 
prior to export to the shapefile deliverable format. This ensures uniform data structure and provides a check on 
all of the datasets. Make an empty copy of the pre-model geodatabase in the Working folder created in step 
3.1. This geodatabase is available from the GIS/Mapping Technical Lead. 

The pre-model geodatabase has empty feature class templates for the eight vector datasets. The feature class 
schema should be fully attributed as the data is generated prior to export as a shapefile. 
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3.3 LINE OF PROTECTION (LOP) CREATION 

The LOP is a 3D feature depicting the top of the levee, the floodwall and the closure structures that are 
surrounding a protected area. Each node on the line should have an elevation (z) value. 

Develop the LOP: 

1. Obtain the NLD for the district. This will be provided by NWK. 

a. Start an edit session in ArcMap. Add the LOP feature class from the pre-model geodatabase in 
the Working folder. 

b. From the NLD, add the levee_centerline, the closure_structure_line, the floodwall_line, and the 
leveed_area features for the study levee to a new ArcMap session. The first three features will 
be combined to depict the LOP for the study levee. The last feature will be provided to the 
modeler as a separate shapefile. 

1) Open FC_SYSTEM table and select from FC_SYSTEM table the system that is required 
for the model 

2) From the Attribute table use the Options button to select related table > FC_SEGMENT 

3) From the FC_SEGMENT table use Options button to select related tables 

a) closure_structure_line, floodwall_line, levee_centerline and leveed_area 

b) The FC_SEGMENT that was selected in the initial table will have all related segments 
selected in the above four tables once they are opened. 

2. Copy and paste the selected Leveed_Area feature class into the pre-Model geodatabase 
Leveed_Areas feature class. 

3. Fill in the attribute table for each leveed area: 

a. [NLDID]—National Levee Database identification number (if applicable) 
b. [MMCID]—Modeling, Mapping and Consequences identification number (not used) 
c. [MMC_Name]—Name of the dam or levee project, same as used in NLD or NID 
d. [MMC_FY]—Fiscal Year of MMC assignment 
e. [Proj_Code]—Three letter code used in file names for pre-model data 
f. [Del_Date]—Assigned delivery due date for pre-model data to modeler 
g. [fc_system_id]—Primary key for the levee system in the NLD. 

4. Export the leveed area to the \GIS_Modeling\Shapefiles folder as a shapefile named using the 
three letter [Proj_Code] and LA separated by an underscore (i.e., SEG_LA.shp). 

5. Select the closure_structure_line, floodwall_line, and levee_centerline features for the study levee. 

a. Export the closure structures to the Working folder as a shapefile named using the three letter 
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[Proj_Code] and CSL separated by an underscore (i.e., SEG_CSL_NLD.shp) 

b. Export the floodwall lines to the Working folder as a shapefile named using the three letter 
[Proj_Code] and FL separated by an underscore (i.e., SEG_FL_NLD.shp) 

c. Export the levee centerlines to the Working folder as a shapefile named using the three letter 
[Proj_Code] and LCL separated by an underscore (i.e., SEG_LCL_NLD.shp) 

6. Use the Project tool (located in the ArcGIS toolbox at Data Management Tools–Projections and 
Transformations–Feature–Project) to change the projection from the NLD projection to the MMC 
projection.  

a. Save the new shapefiles to the GIS_Modeling/Shapefiles folder and name them 
[Proj_Code]_CSL.shp, [Proj_Code]_FL.shp, and [Proj_Code]_LCL.shp, respectively. 

7. Copy and paste those three new Shapefile layers—[Proj_Code]_CSL, [Proj_Code]_FL and 
[Proj_Code]_LCL—into the LOP feature class in the pre-model geodatabase. Save edits. 

a. If there is only one levee_centerline for the study levee, then the LOP is complete. If there is 
more than one levee_centerline, but there are no floodwall_line or closure_structure_line 
features for the study levee, then select all of the levee_centerline features for the study levee 
and merge them into one line. 

1) After selecting the levee_centerline feature, go to the Editor toolbar and click on the merge 
tool. Merge into one line. 

b. For closure_structure_line in the LOP a determination needs to be made if the structure was 
collected open or closed when elevation data was collected. The expectation is that the 
closure was collected open, i.e., the vertices that aren’t terminal will be lower than the terminal 
vertices which actually determine the height of the closure. If the closure was collected while 
open, the following edits must be made.  

Note 

Some closure structures will not be as described and may need special 
consideration. 

1) Zoom to the location of the closures and double click the line segment that came from the 
closure 

2) Press the sketch properties button  

Figure 3-1. Editor toolbar 
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3) Identify the vertices with elevations lower than the first and last and delete them 

4) Repeat process for all closure structures in the LOP, save edits, and stop editing. 

5) Visually verify in ArcScene that the low portions of the LOP were removed 

6) Add LOP and closure structures to view 

c. Some LOP editing may be required to close the LOP, example: if high ground exists as LOP 
the line may need to be closed, being mindful of capturing elevation for any added vertices. 

1) Utilize the Edit Sketch Properties tool on the Editor toolbar to ensure consistency in the 
LOP’s elevation 

d. In cases where there is a gap in the LOP due to a missing structure, or other reason, a 
segment should be added manually. No additional vertices are needed, but there does have to 
be a line there in order for it to go into Flo2D. 

  

Figure 3-2. Edit Sketch Properties 
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Figure 3-3. Example Edit Session 

1) In an edit session, use the sketch tool to extend the line across the gap. Set snapping to 
“vertex” and “end” to avoid pesky under and overshoots. 

2) With the edit select tool, double click on the arc that you snapped to, and note the Z value 
of the vertex you snapped to.  

3) Press the sketch properties button as above, and locate the vertex with Z=0.00. This will 
be the vertex at the end of the line segment that was just digitized. Edit the Z value to be 
equal to the value noted in 7.d.2.  

4) Save edits. 
5) Visually verify in ArcScene that the low portions of the LOP were removed. 

8. Once the LOP has been modified to depict continuity in its elevation (z) values, merge the LOP 
into one continuous line. 

a. Select all of the LOP features, go to the Editor toolbar and click on the merge tool.  

b. Merge into 1 line. 

9. Fill in the attribute table for the LOP: 

a. [NLDID]—National Levee Database identification number (if applicable) 
b. [MMCID]—Modeling, Mapping and Consequences identification number (not used) 
c. [MMC_Name]—Name of the dam or levee project, same as used in NLD or NID 
d. [MMC_FY]—Fiscal Year of MMC assignment 
e. [Proj_Code]—Three letter code used in file names for pre-model data 
f. [Del_Date]—Assigned delivery due date for pre-model data to modeler 
g. [fc_system_id]—Primary key for the levee system in the NLD 
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10. Export the centerline to the \GIS_Modeling\Shapefiles folder as a shapefile named using the three 
letter [Proj_Code] and LOP separated by an underscore (i.e., SEG_LOP.shp). 

3.4 CENTERLINE CREATION 

The centerline may be digitized as a shapefile and then imported into the centerlines feature class in the pre-
model geodatabase or digitized directly into the feature class. The centerline should be digitized so it goes past 
the levee extent at least three miles in each direction. If a centerline has already been created in the pre-model 
geodatabase, that centerline may be used; however, modify the attributes in the shapefile as necessary. 

Digitize the centerline: 

1. The most current available aerial imagery is used as the background data. If a project-specific 
image service is unavailable, use the ESRI world imagery service to digitize the centerline at a 
minimum scale of 1:15000. 

2. The centerline must be digitized from upstream to downstream. 

3. The centerline must be generated as a single continuous line feature. 

4. If the centerline was digitized as a shapefile, load that feature into the centerlines feature class in 
the Pre-Model geodatabase, otherwise skip to step 5. 

5. Fill in the attribute table for the centerline: 

a. [NIDID]—National Inventory of Dams Identification number (not applicable) 
b. [NLDID]—National Levee Database Identification number (if applicable) 
c. [MMCID]—Modeling, Mapping and Consequences Identification number (not used) 
d. [MMC_Name]—Name of the dam or levee project, same as used in NLD or NID 
e. [MMC_FY]—Fiscal Year of MMC assignment 
f. [Proj_Code]—Three letter code used in file names for pre-model data 
g. [Del_Date]—Assigned delivery due date for pre-model data to modeler. 

6. Export the centerline to the \GIS_Modeling\Shapefiles folder as a shapefile named using the three 
letter [Proj_Code] and CL separated by an underscore (i.e., SEG_CL.shp). 

3.5 BANKLINE CREATION 

The banklines may be digitized as a shapefile and then imported into the banklines feature class in the pre-
model geodatabase or digitized directly into the feature class. 

Digitize the Banklines: 

1. The most current available aerial imagery is used as the background data. If a project specific 
image service is unavailable, use the ESRI world imagery service to digitize the banklines at a 
minimum scale of 1:15000 from the dam to the same downstream extent as the centerline. 

2. The banklines must be digitized from upstream to downstream. 
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3. The banklines must be digitized along the right and left descending banks as separate features in 
the same feature class. 

4. If the banklines were digitized as a shapefile, load those features into the banklines feature class in 
the pre-model geodatabase, otherwise skip to step 5. 

5. Fill in the attribute table for each bankline: 

a. [NIDID]—National Inventory of Dams identification number (not applicable) 
b. [NLDID]—National Levee Database identification number (if applicable) 
c. [MMCID]—Modeling, Mapping and Consequences identification number (not used) 
d. [MMC_Name]—Name of the dam or levee project, same as used in NLD or NID 
e. [MMC_FY]—Fiscal Year of MMC assignment 
f. [Proj_Code]—Three letter code used in file names for pre-model data 
g. [Del_Date]—Assigned delivery due date for pre-model data to modeler. 

6. Export the banklines to the \GIS_Modeling\Shapefiles folder as a shapefile named using the three 
letter [Proj_Code] and BL separated by an underscore (i.e., SEG_BL.shp). 

3.6 VERTICAL DATUM CONVERSION POINT CREATION 

The Vertical Datum Conversion Points are generated to provide the modeler with a conversion value to use in 
converting existing elevation data from the NGVD 29 vertical datum to the NAVD 88 vertical datum mandated 
for all new modeling efforts. These conversion points are provided every five miles along the digitized 
centerline. Conversion values are pulled from a raster dataset of conversion values generated at a one-
kilometer spatial resolution using the USACE CorpsCon conversion software. This raster dataset is available 
from the GIS/Mapping Technical Lead. 

Prerequisites: 

• Centerline shapefile must be digitized 
• ESRI ArcGIS Spatial Analyst extension must be installed and enabled. 

Generate Conversion Points: 

1. Add the Conversion_Points and the centerlines feature classes from the pre-model geodatabase to 
an empty ArcMap document. 

2. Start an edit session and set the editing target to the Conversion_Points feature class. 
3. Using the feature select tool, select the centerline in the map. 
4. Click on the Editor drop-down and choose the Divide command. 
5. Elect to place points separated by every 26,400 units (feet) (every five miles). 
6. Click OK. The points should be placed every five miles along the centerline. 
7. Save edits and exit the edit session. 

Extract the Conversion Raster Values: 

1. Add the cf29to88 conversion value raster to the data frame. 
*If this layer is not available contact NWK-ED-GS 
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2. In ArcToolbox, click on Spatial Analyst Tools, choose Extraction, and then choose Extract Values 
to Points. 

3. Select the Conversion Points feature class as the input point features. 
4. Select the cf29to88 DEM as the Input raster. 
5. Save the output shapefile to the working folder and name it “[Proj_Code]_Extract.shp” 
6. Do not check the box to Interpolate values at point locations. 
7. Click OK. 

Populate the Attribute Table: 

1. Join the attribute table of the newly generated point shapefile to the Conversion_Points feature 
class using the OBJECTID fields. 

2. Using the field calculator, calculate the CONVDELTA field from the Conversion_Points feature 
class to equal the RASTERVALU from the extracted points. 

3. Remove the Join. 

4. Fill in the rest of the attribute table for the conversion points: 

a. [NIDID]—National Inventory of Dams identification number (not applicable) 
b. [NLDID]—National Levee Database identification number (if applicable) 
c. [MMCID]—Modeling, Mapping and Consequences identification number (not used) 
d. [MMC_Name]—Name of the dam or levee project, same as used in NLD or NID 
e. [MMC_FY]—Fiscal Year of MMC assignment 
f. [Proj_Code]—Three letter code used in file names for pre-model data 
g. [Del_Date]—Assigned delivery due date for pre-model data to modeler. 

5. Export the conversion points to the \GIS_Modeling\Shapefiles folder as a shapefile named using 
the three letter [Proj_Code] and Conv separated by an underscore (i.e., SEG_Conv.shp). 

3.7 BUFFER CREATION FOR DIGITAL ELEVATION MODEL COMPILATION 

Buffer the Leveed Area: 

1. In a new ArcMap document add the leveed area, [Proj_Code]_LA.shp.  

2. Use the buffer tool (Analysis Tools>Proximity>Buffer) to buffer the leveed area so that it covers the 
leveed area and river extents. A default buffer of three miles can be used, but review the 
topography to ensure that the floodplain is covered by the leveed area buffer. 

a. Set the Dissolve Type to ALL. 

b. Save the output as [Proj_Code]_LA_Buffer.shp in the GIS Modeling/Working folder 

3. Verify that only one polygon has been created. 
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Figure 3-4. Buffer tool 

Project the Leveed Area Buffer: 

In order to use the buffer to set the extent of the DEM, it must be in the same projection as the DEM tiles. 

1. Use the Project tool (located in the ArcGIS toolbox at Data Management Tools–Projections and 
Transformations–Feature–Project) to change the projection from the MMC projection to the same 
projection as the DEM tiles by importing the projection from one of the DEM tiles. If another 
elevation source is to be used, use the projection that source is provided in. 

2. Save the new shapefile to the Working folder and name it [Proj_Code]_LA_Buffer_Geo. 

3.8 Digital Elevation Model Compilation 

Prerequisites: 

• All of the DEM tiles must have a correctly defined projection. 
• The map document dataframe must be set to the DEM projection. 
• The Leveed Area Buffer must be in the same projection as the DEM tiles. 

Find which tiles are needed: 
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1. In a new ArcMap, load the leveed area buffer shapefile that was projected to the DEM native 
projection in the working folder and the DEM_Extents shapefile. (Should be located with the NED 
data) 

2. Click on the Selection tab on the top of the screen and choose Select by Location. 

3. Select features from the DEM_Extents layer that intersect features in the Study Area layer. 

4. The selected DEM tiles are the tiles that will need to be merged in the next step. 

Merge the DEM Tiles (only if there is more than one DEM tile):  

1. Load the DEM tiles selected in the previous step into the ArcMap document by using the attribute 
table of DEM Extents to locate them on disc.  

Note 

To prevent waiting on DEM tiles to display, it is useful to set ArcMap to not display 
layers as they are loaded. 

2. Set the analysis extent of the Spatial Analyst extension to the extent of the leveed area buffer layer 
using the Options selection on the Spatial Analyst toolbar dropdown menu. 

3.  Using the raster calculator located in the Spatial Analyst toolbar dropdown, merge the DEMs using 
the following function:  

“Merge([DEM1], [DEM2], [DEM3]…)” 

The merge function works with the command “merge” followed by a comma separated list of 
raster datasets contained in parenthesis. 

Note 

If more than ten DEM tiles are to be merged, it is wise to do this step using about 
half of the tiles on the first run, then the other half, and then merging the two results 
together. 

Convert the vertical units from meters to feet: 

If the DEM tiles did not need to be merged because only one DEM tile covered the extent of the leveed 
area buffer, the analysis extent in the Spatial Analyst toolbar needs to be set. Go to Options and then 
go to the Extent tab to set the Extent Analysis to the leveed area buffer with the same projection as the 
DEM tiles. 

Using the raster calculator again, multiply the resulting DEM (named Calculation) by 3.28084 to 
convert the vertical units from meters to feet. 

Make the DEM permanent: 
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1. Right click on the Calculation2 (or the Calculation layer if no tiles were merged) layer resulting from 
the raster calculator function. 

2. Choose Make Permanent and store the raster in ESRI Grid format as [Proj_Code]_DEM_Geo in 
the \GIS_Modeling\DEMs folder. If the modeling team needs the DEM in a different projection, this 
is the layer they will start from. 

Project the DEM: 

1. Use the Project Raster tool (located in the ArcGIS toolbox at Data Management Tools–Projections 
and Transformations–Raster–Project Raster) to set the projection of the DEM to the MMC project 
projection.  

2. Set the output raster to [Proj_Code]_DEM_MMC in the \GIS_Modeling\DEMs folder.  

3. Set the output projection to the MMC projection. 

4. Set the output cell size as 32.808 feet. 

IMPORTANT 

Set the resampling method to Bilinear instead of the Nearest Neighbor default 
option. 

3.9 CREATE POINTS FROM LOP 

Densify LOP: 

1. A script was developed to densify the LOP vertices by inserting additional vertices to ensure that a 
vertice is present every ten feet. The script will output a point shapefile with Z-enabled values. 

2. Start a new ArcMap.  

3. Add a new toolbox. 

a. Open ArcToolbox and right-click on it. Select New Toolbox. 
b. A new Toolbox has been added. Rename as MMC Pre-Model Tools 

4. Right-click on the new toolbox that was created and select Add>Script.  

a. On the first screen set the Name and Label as DensifyLine. Click Next. 
b. Navigate to the Python Script file. Click Next. 
c. Set the Parameters. Click Next. 

1) Display Name=Input, Data Type=Shapefile, and, under Parameter Properties, 
Direction=Input 

2) Display Name=Ouput, Data Type=Shapefile, and, under Parameter Properties, 
Direction=Output 
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3) Display Name=Tolerance, Data Type=Long, and, under Parameter Properties, 
Direction=Input, Default=10 

Figure 3-5. Add Script 

d. Click Finish. 

5. Densify the Line every 10 feet. 

a. Set the input to the LOP shapefile in the GIS_Modeling\Shapefiles folder 

b. Set the output to the Working folder and name it [Proj_Code]_LOP_Points 

c. Set the tolerance to ten feet.  

1) Verify that the ArcMap layer spatial reference is set to the MMC projection.  
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Figure 3-6. Densify Line tool 

6. Add XYZ coordinates to the point shapefile.  

a. Go to Data Management>Features>Add XY Coordinates. This tool will also add Z-values. 

3.10 CREATE A DISTANCE RASTER 

1. Create a Buffer of the LOP 

a. In a new ArcMap document, add the LOP line. 

b. Use the buffer tool to buffer the LOP to half of the average width of the levee sloping surface 
as measured from aerial photography to create a polygon shapefile in the Working folder. 

Note 

If one side of the LOP is shorter than the other side, use the longer side to assure 
the buffer covers the entire levee. 
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1) Set the Dissolve Type to ALL. 

Figure 3-7. Buffer tool 

2) Save the output as [Proj_Code]_LOP_Buffer.shp in the Working folder 

c. Verify that only one polygon has been created. 

2. Set the Environmental Extents to the same as the buffer.  

a. Go to the Spatial Analyst toolbar and click the drop-down menu. Click Options and go to the 
Extent tab. Set the Analysis extent to the same extent as the LOP Buffer. 
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Figure 3-8. Environmental Extents 

3. Go to Spatial Analyst Tools>Distance>Euclidean Distance. 

4. Set the input data as the LOP line. 

5. Set the Output as [Proj_Code]_Euc_Dis in the Working folder 

6. Set the Max Distance as one cell size more than the buffer distance used to create the Study Area. 
For DEMs from the NED, one cell size more would be 10 meters or 32.808 feet. 

7. Output the cell size to the same as the DEM, which is 10 meters or 32.808 feet.  
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Figure 3-9. Euclidean Distance Tool 

3.11 CREATE TOP OF LEVEE SURFACE 

1. Create Thiessen Polygons 

a. Make sure that the Environmental Extents is set to be the same as the buffer. Go to the Spatial 
Analyst toolbar and click the drop-down menu. Click Options and go to the Extent tab. Set the 
Analysis extent to the same extent as [Proj_Code]_LOP_Buffer.shp. 

b. In ArcToolbox, go to Analysis Tools>Proximity>Create Thiessen Polygons 

c. Set the input feature as the point shapefile created from the Z-enabled points created by the 
script. 

d. Set the output feature class to the Working Folder. Set the name to be [Proj_Code]_TP.shp 

e. Set the output fields to All. 

Figure 3-9. Create Thiessen Polygons tool 
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2. Clip Thiessen Polygons 

a. In ArcToolbox, go to Analysis Tools>Extract>Clip 

b. Set the input feature as the Thiessen Polygons created in the last step 

c. Set the clip feature as the buffer 

d. Set the output as [Proj_Code]_TP_Clip.shp in the Working folder. 

Figure 3-10. Clip Tool 

3. Convert to Raster 

a. Make sure the Environmental Extents is set to be the same as the buffer. Go to the Spatial 
Analyst toolbar and click the drop-down menu. Click Options and go to the Extent tab. Set the 
Analysis extent to the same extent as [Proj_Code]_LOP_Buffer.shp. 

b. Click on the drop-down menu on the Spatial Analyst toolbar, go down to Convert, and select 
the Features to Raster tool. 

c. Set the input feature to the clipped Thiessen polygon 
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d. Set the field as the Z-Value 

Figure 3-11. Feature to Raster Conversion Tool 

e. Set the output cell size to be the same as the DEM, 10 meters or 32.808 feet 

f. Set the output raster as [Proj_Code]_TP_Grid in the Working folder. 

3.12 CREATE SLOPED LEVEE SURFACE 

1. Set the Environmental Extents to be the same as DEM_MMC. Go to the Spatial Analyst toolbar 
and click the drop-down menu. Click Options and go to the Extent tab. Set the Analysis extent to 
the same extent as DEM_MMC. 

2. A default levee side slope of 1/3 is used in the Raster Calculator to adjust the slope based on 
distance. 

3. Go to the Spatial Analyst drop-down menu on the toolbar and click on the Raster Calculator tool. 

4. In the Raster Calculator, use the following formula: 

a. [[Proj_Code]_TP_Grid]-([[Proj_Code]_Euc_Dis]/3) 
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Figure 3-12. Raster Calculator 

a. Using the result Calculation, convert NoData to -100 with the Raster Calculator. Use the 
following formula: Con(IsNull([Calculation]), -100, [Calculation])  

b. Click Evaluate 

Figure 3-13. Raster Calculator 

c. Right-click on the new raster, click on Data and then Make Permanent. Export it to the Working 
folder and name it [Proj_Code]_SLS. 
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3.13 BURN SLOPED SURFACE INTO PROJECTED DEM 

1. Use the DEM with the MMC projection. 

2. Make sure that the Analysis Extents in the Spatial Analyst toolbar are set to the extent of the DEM 
with the MMC projection. 

a. Go to the Spatial Analyst drop-down menu and select the Raster Calculator. Use the following 
equation: Max([[Proj_Code]_DEM_MMC],[[Proj_Code]_SLS])  

b. Make raster permanent. Save as [Proj_Code]_MMC_Lev in the GIS_Modeling/DEMs folder. 

Figure 3-14. Raster Calculator 

3.14 RESAMPLE DIGITAL ELEVATION MODEL 

1. Make sure that the Analysis Extent is set to the DEM with the MMC projection. 

2. In ArcToolbox, go to Data Management Tools>Raster>Raster Processing>Resample. 

3. Set the input feature as the Raster [Proj_Code]_MMC_Lev. 

4. Set the Output cell size as 50. If the system is very large, it may be necessary to resample the 
output cell size at 100. 

5. Set the resampling method to Bilinear. 
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6. Save the output raster to the GIS Modeling/DEMs folder as [Proj_Code]_ MMC_Lev_R. 

Figure 3-15. Resample Raster Tool 

3.15 CONVERT RASTER TO ASCII FILE 

1. In ArcToolbox, go to Conversion Tools>From Raster>Raster to ASCII 

2. Set the input raster as the output of the Resample: [Proj_Code]_MMC_Lev_R 

3. Output the file as an .ASC file and set the name as [Proj_Code]_MMC_Lev_R_ASC 

Figure 3-16. Raster to ASCII Tool 

3.16 HILLSHADE CREATION 

Generate the hillshade from the projected DEM with the levee burned in: 

1. Make sure that the Analysis Extent is set to the DEM with the MMC projection. 

2. Choose the Hillshade tool from the Surface Analysis list under the Spatial Analyst drop-down. 
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3. Set the Input Target to [Proj_Code]_MMC_LEV 

4. For the remainder of the inputs use the default settings to generate the hillshade dataset named 
[Proj_Code]_HLS in the \GIS_Modeling\DEMs folder. 
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Deliverable Organization 
Organize the Data into the correct Folders: 

1. In ArcCatalog, organize the shapefiles and rasters created in the previous steps to match the 
deliverable schema in Figure 1. If the files were saved into the correct folders during production 
they don’t need moved around, only their location verified. 

2. Ensure only the final versions of the datasets are included in the deliverable folders and leave all 
intermediate datasets in the working directory. 

4.1 BASEMAP.MXD SETUP 

An ArcMap .mxd document is provided to the modeling team to provide a first look at the data developed in the 
pre-model processes. The basemap can be generated from scratch or an existing basemap.mxd can be used 
and the data sources changed for each of the layers. The steps below describe generating the .mxd from 
scratch.  

1. Open a new .mxd in ESRI ArcMap and follow the steps below to generate the document to provide 
to the modeling team. 

2. Add each of the final layers to the GIS document from their final location in the folder structure.  

3. Make sure the relative path names option is selected in the document properties, under data 
source options. 

4. The layers should appear in the table of contents top to bottom in the following order: 

• Conversion Points  

o Symbology: Circle, size 7, Black. 

• Levee Line of Protection  

o Symbology:  

- Layer 1: Cartographic Line Symbol, Width 7, Autunite Yellow  
- Layer 2: Cartographic Line Symbol, Width 14, Steel Blue 
- Layer 3: Marker Line Symbol (Unicode 88), Size 14, Steel Blue 

• Leveed Area 

o Symbology: Outline Width 0.40 
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- Layer 1: Line Fill Symbol, RGB (64,101,235), Angle 45, Offset 0.003, Separation 
0.0018 

- Layer 2: Line Fill Symbol, RGB (151,219,242), Angle 45, Offset 0, Separation 
0.0018 

• Centerlines  

o Symbology: Line, Width 1, RGB (10,147,252) 

• DEM (DEM with Burned-In Levee, but not Resampled) 

o  Symbology: Default (turned off) 

• Hillshade 

o  Symbology: Default (turned off) 

• ESRI Layers (ESRI Layer files provided by NWK) 

o Demographics/USA_Population_Density (turned off) 

o World Imagery (turned off) 

o US Topo Maps (turned off) 

o World Street Map 

o Shaded Relief (turned off) 

5. Save the .mxd into the ArcGISMaps folder as BaseMap.mxd or [Proj_Code]_BaseMap.mxd.
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Data Manifest 
The Data Manifest should give a short description of the datasets that reside in each folder and of the 
organization responsible for the creation of the datasets. The manifest should be stored in a MS Word 
document in the \[Study_Levee_Name]\[Year - Draft or Final]\GIS_Modeling folder. Use the example below as 
a template for the structure of the manifest. 

Example Manifest: 

Study Area: [Study Area] 

Study Area folder contains this data manifest and the production documentation describing the 
data development steps taken by the GIS team. Also contains all of the blank folders for use in 
later steps in modeling, mapping and consequence estimation. 

\GIS_Modeling\ArcGISMaps 

Contains the .mxd document with links to each of the datasets for this study area. 

\GIS_Modeling\DEMs 

Contains (list the raster datasets and any issues that might need to be addressed for 
any of the datasets) 

\GIS_Modeling\ASCII 

Contains (list the files and any issues that might need to be addressed for any of the 
files) 

  \GIS_Modeling\Projections 

   Contains the ESRI .prj file for the MMC projection 

\GIS_Modeling\shapefiles 

Contains (list the shapefiles and any issues that might need to be addressed for any of 
the datasets) 

Data Completed By: 

 GIS/Mapping Team Member 

 District 

 Contact Information 

Include entries for all folders that contain data. Modelers and Economists should add to this document as more 
data is added to the folder structure. 
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Data Transfer 
The data compiled and generated through the previous steps must be transferred to the H&H team to begin the 
modeling portion of the MMC process. One copy of the data will be sent to the modeler (all folders except for 
the working folder) and a full copy (including the working folder) will be saved in a central location by NWK.  

1. Complete the checklist in Appendix 4.3.2, Pre-model Deliverable Checklist. 

2. Use a commercial parcel delivery company (UPS, FedEx) to ship the data to the assigned H&H 
modeling team member as assigned. 
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